Installing Rudiments Prerequisites Platforms

Rudiments is supported on a variety of Linux/Unix systems and Windows. Building Rudiments on these platforms requires the installation of a compiler toolchain and other bits of optional software. Instructions follow for many supported platforms.

Linux

Rudiments is supported on a variety of Linux platforms including Fedora, CentOS, OpenSuSE, Debian, and Ubuntu.

Fedora

To install all of the prerequisites at once, execute the following command, as root:

dnf -y install gcc-c++ make readline-devel openssl-devel krb5-devel pcre-devel libcurl-devel

The gcc-c++ and make packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the pcre-devel package.

Note that on older Fedora platforms, the yum package manager is used instead of the dnf package manager. The syntax for the two is the same though, just replace dnf with yum in the command above.

CentOS

To install all of the prerequisites at once, execute the following command, as root:

yum -y install gcc-c++ make readline-devel openssl-devel krb5-devel pcre-devel libcurl-devel

The gcc-c++ and make packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the pcre-devel package.

OpenSuSE

To install all of the prerequisites at once, execute the following command, as root:

zypper install gcc-c++ make readline-devel libopenssl-devel krb5-devel pcre-devel libcurl-devel

The gcc-c++ and make packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the pcre-devel package.

Ubuntu

To install all of the prerequisites at once, execute the following command, as root:

apt-get install g++ make libreadlne-dev libssl-dev libkrb5-dev libpcre3-dev libcurl4-openssl-dev

The g++ and make packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the libpcre3-dev package.

Debian

To install all of the prerequisites at once, execute the following command, as root:

apt-get install g++ make libreadline-dev libssl-dev libkrb5-dev libpcre3-dev libcurl4-openssl-dev

The g++ and make packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the libpcre3-dev package.

Unix

Rudiments is supported on a variety of Unix platforms including FreeBSD, NetBSD, OpenBSD, and Minix.

FreeBSD

To install all of the prerequisites at once, execute the following command, as root:

pkg install clang gmake pkgconf readline openssl pcre curl

The clang and gmake packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the pcre package.

Note that on older FreeBSD platforms:

Kerberos/GSSAPI is installed as part of the base installation.

NetBSD

To install all of the prerequisites at once, execute the following command, as root:

pkgin install g++ gmake readline openssl pcre curl

The g++ and gmake packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the pcre package.

Kerberos/GSSAPI is installed as part of the base installation.

OpenBSD

To install all of the prerequisites at once, add a line to /etc/pkg.conf like:

installpath = ftp://ftp.usa.openbsd.org/pub/OpenBSD/5.8/packages/amd64/

(replacing 5.8 with the version of OpenBSD that you are using and replacing amd64 with the architecture given by uname -m)

... and execute the following command, as root:

pkg_add -r g++ gmake readline heimdal pcre curl

The g++ and gmake packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the pcre package.

OpenSSL is installed as part of the base installation.

Minix

To install all of the prerequisites at once, execute the following command, as root:

pkgin install clang binutils gmake readline openssl heimdal pcre curl

The clang, binutils, and gmake packages are required, but the rest are optional and may be omitted as appropriate. For example, if you don't need PCRE support, then you can omit the pcre packages.

Windows

Rudiments is supported on a variety of Windows platforms. Building Rudiments on these platforms just requires the installation of a compiler toolchain.

Rudiments can be built using the Microsoft Visual Studio and Visual Studio Express toolchains. Visual Studio Express can be downloaded for free from Microsoft and the installer is intuitive.